当前位置:首页 >  问答

通达信百分比指标运用

我来帮TA回答

通达信怎么把副图指标值按比例缩放在-100到100之间

这个很简单,发源码出来,立马i修改

通达信公式,如何把每次设置的买卖点的盈亏统计百分比标记在H*1.2

难怪高分也没人回答,没头没脑的一句公式你要别人怎么来帮你改?再说了,每次买卖做统计,怎么设置买的时间,光靠公式只能做到告诉你何时买,是否买了公式又怎么会知道?

通达信里的相对流量指标怎么用

TYP := AMOUNT/VOL/100;
V1:=SUM(IF(TYP>REF(TYP,1),TYP*VOL,0),21)/SUM(IF(TYP<REF(TYP,1),TYP*VOL,0),21);
MFI:=100-(100/(1+V1));
资金流向:EMA(MFI,5),COLORBLUE;
DRAWTEXT(BARSLASTCOUNT(COUNT(资金流向<50,200)/COUNT(资金流向>50,200)<0.2 )=1 AND 50<(C-LLV(C,200))/(HHV(C,200)-LLV(C,200))<80,40,'主力吸筹');
A:=AMOUNT/VOL/100;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
工作线:=EMA(X,13);
DRAWTEXT(资金流向>=HHV(资金流向,20) AND MA(VOL,20)>REF(MA(VOL,20),1) AND MA(VOL,5)>MA(VOL,10)
AND MA(C,238)>REF(MA(C,238),1) AND C>工作线 AND CROSS(资金流向,60),资金流向,'买');
IF(资金流向<50,资金流向,DRAWNULL),COLORGREEN;
IF(资金流向>80,资金流向,DRAWNULL) ,COLORYELLOW;
IF(资金流向<80 AND 资金流向>60,资金流向,DRAWNULL),COLORRED;
IF(资金流向>50 AND 资金流向<=60,资金流向,DRAWNULL),COLORYELLOW;
STICKLINE(C,30-0.5,30,1.5,0),COLORWHITE;
STICKLINE(C,50-0.3,50,1.5,0),COLORYELLOW;
STICKLINE(C,60-0.3,60,1.5,0),COLORLIGRAY;
STICKLINE(C,70-0.4,70,1.5,0),COLORLIRED;
STICKLINE(C,80-0.3,80,1.5,0),COLORRED;
建为附图指标,再在K线图中调出来即可。
参考资料:http://tieba.baidu.com/f?kw=%B9%C9%C6%B1%B9%AB%CA%BD%D7%A8%BC%D2

通达信哪些指标公式好用啊 ?太多了 怎么选啊

通达信软件系统中自带很多指标公式,可根据每个人炒股方式方法,短期用波段、超买超卖类型的,长期的用大势、趋势类型,就看个人的爱好喽。众多的常用指标只能做为参考,只要你把其中一个指标学精整通都会运用的很好的。如cci,macd,rsi,kdj等虽大家都用,但每个人领会的不同,产生的结果相差万里喽。所以没有什么好指标,坏指标之说,适合自己的并精通的就是最好的指标喽。下面送给你本人自用的简单实用的指标公式原码一个,认真去操作就会明白,大道至简的方法。顶:PEAK(CLOSE,10,1);
底:TROUGH(CLOSE,10,1),COLORCYAN;
DRAWICON(CROSS(ZIG(3,10),REF(ZIG(3,10),1)),LOW*0.97,7);
DRAWTEXT(CROSS(ZIG(3,10),REF(ZIG(3,10),1)),LOW*0.94,'买入');
DRAWICON(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.04,8);
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.01,'止损');

怎么用通达信指标表示,1、前一波的最高点和此高点前的第一个波底 2、前一波的最高点距离现在跌幅多少

先不考虑如何用公式表示高点,先考虑如何用你的语言描述符合什么条件才算高点,
然后根据通用的语言做通用的公式

求一个通达信的在牛市里面很准的无未来函数的短线买点指标

{ok.奉献一个很准的无未来函数的短线买点指标给楼主}
O1:(SUM(EMA((CLOSE+LOW)/2,1)/3,3)),COLOR00FFFF,LINETHICK1;
O2:EMA(O1,3),COLORFF00FF,LINETHICK1;
O3:EMA(O2,3),COLOR00FF00,LINETHICK1;
AAA:=CROSS(O1,O2) AND CROSS(O2,O3) AND CROSS(O1,O3),LINETHICK1;
DRAWICON(AAA,O1*0.95,17);
MMM:=MA(CLOSE,20);
PEAK1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(PEAK1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND PEAK1;
VAR1A:=REF(PEAK1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3.2,0),COLORFF3300;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2.7,0),COLORFF5500;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2.1,0),COLORFF7700;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),1.5,0),COLORFF9900;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),0.9,0),COLORFFBB00;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),0.3,0),COLORFFDD00;
DRAWICON(FILTER(VAR19=1,5),LOW*0.995,9);{通达信只要把最后的数字8改成自己喜欢的图形对应的数字}
DRAWICON(FILTER(VAR1A=1,5),HIGH*1.008,0);{通达信只要把最后的数字5改成自己喜欢的图形对应的数字}
DRAWICON(FILTER(VAR1A=1,5),HIGH*1.03,15);{通达信只要把最后的数字3改成自己喜欢的图形对应的数字};